Cloudflare outage is affecting reporting

Incident Report for Together Platform

Resolved

Cloudflare has confirmed the issue is resolved. Reporting is fully functional in Together.
Posted Nov 18, 2025 - 09:17 CST

Identified

Our reporting provider is currently impacted by Cloudflare's outage, and as such, reporting is not available in the Together platform.

Cloudflare outage details:
https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 08:10 CST
This incident affected: Org Adminsitration.