App slow to load
Incident Report for Together Platform
Resolved
We determined that our hosting provider, Google, had an interruption. This lasted for about 30 minutes - 60 minutes.
Posted Nov 16, 2020 - 10:11 CST
Investigating
We are currently investigating reports that Together platform will not load / 503 error code.
Posted Nov 16, 2020 - 09:49 CST
This incident affected: Critical Infrastructure (Web Hosting).