Email vendor outage

Incident Report for Together Platform

Resolved

The vendor has resolved the incident and email delivery is restored
Posted May 27, 2024 - 15:16 CDT

Monitoring

A fix has been implemented and results are being monitored
Posted May 27, 2024 - 09:22 CDT

Identified

Our email vendor, Mailgun, is having an outage, and at the moment there are deliverability issues for emails from the platform. The vendor is aware and investigating.
Posted May 27, 2024 - 08:35 CDT
This incident affected: Notifications.