Some users are having trouble connecting to my.togetherplatform.com
Incident Report for Together Platform
Resolved
The connectivity issues we were experiencing in US Central have been resolved.
Posted Jul 09, 2019 - 22:00 CDT
Identified
Engineers have identified an issue and a fix is being deployed.
Posted Jul 09, 2019 - 21:54 CDT
Investigating
We're experiencing elevated levels of connectivity errors to our web-hosting. Engineers are currently looking into the issue.
Posted Jul 09, 2019 - 21:52 CDT
This incident affected: Login/SSO, User Portal, Org Adminsitration and Critical Infrastructure (Web Hosting).